CISCOのルータ設定

使用機器:CISCO C841M

何とか設定ができたが、評判通りややこしい。失敗しないように覚書として残しておく。

機器との接続

Cisco Systems Cisco RJ-45 DB-9 シリアルケーブル

Tera Term

機器にログイン

*初期(ワイタイムなので気を付ける)
name:cisco
pass:cisco

ユーザ権限の変更

ユーザの権限は下記のとおりである。必要な実行コマンドによって、権限を変更する。

commandには一般(>)、特権(#)、設定(config)の3モードがある
設定モード時に特権コマンドを使用する場合は、do を前につける

一般←特権 disable
一般→特権 enable

特権→設定 configure terminal または conf t
特権←設定 exit

初期コンフィグのバックアップ

これをしておかないと、初期化できなくなる。実行前に必ずルータにUSBメモリを指しておく。

copy startup-config usbflash0:config-factory

コンフィグのリストア

USBにコンフィグを入れて、以下のコマンドを実行する。

copy usbflash0:ファイル名 startup-config
reload

 

定期的なコンフィグのバックアップ

定期的なコンフィグのバックアップを必ずすること。

copy startup-config usbflash0:config-history*

Cisco Configuration Professional Expressで初期設定

CCPE(10.10.10.1)のクイックセットアップウィザードで基本的な設定を実施

初期設定
ホスト名 raccoonドメインネーム 適当でよい
タイムゾーン (GMT+09:00) Osaka, Sapporo, Tokyo
NTP設定 ntp.jst.mfeed.ad.jp
WAN接続タイプ Ethernet(Direct/PPPOE)
インターフェース GigaEthernet0/4 (下側コネクタ)
DNS/IPアドレス
[*] ISPから直接DNSサーバ情報を取得する
設定後学内DNSを設定
IPV4
学内申請で取得したIP、サブネットを指定
[*] NATを有効にする
IPV6
[ ] IPv6 を有効にする
[ ] PPPoE を有効化
バックアップ WAN
[ ] バックアップWANを有効化
LAN
ここでは変更不可
LANネットワーク 10.10.10.0
サブネットマスク 255.255.255.128 (256個 ではなく 128個 しか確保されていない)
利用可能なIPサイズ ルータを含む 126 のホスト
これはアドレス範囲の 128個 から ネットワークアドレス=0 と ブロードキャストアドレス=127 を除いた 126個
LAN Interface [GigabitEthernet0/0, GigabitEthernet0/1, GigabitEthernet0/2, GigabitEthernet0/3, Vlan1]
セキュリティの設定
すべてチェック

追加設定

これだけではネットに繋がらないので以下の設定を行う。

基本設定
  DNSを設定
  DHCPを編集
   デフォルトルータを編集 

 

ターミナルのコマンド上(設定モード)で以下のコマンド実施(ルーティングの設定)

conf t
ip route 0.0.0.0 0.0.0.0 10.1.1.1
reload

 

以下の設定を必ず削除する(WEB設定で削除すると楽)。そうしないと繋がらない

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/4

これで、一応、ネットにはつながる。

VLANを追加

DHCPを192.168.50.0のネットワークを構築(以下が作業の流れ)

cpp-pool という既存の DHCP プールは設定用に必要となるため、 別に新しく DHCP の設定を作って使う。

VLANの作成
[基本設定]のDHCP の [追加] から、
プール名 raccoon-dhcp
プールネットワーク 192.168.50.0
サブネットマスク 255.255.255.0
デフォルトルート 192.168.50.1
この DHCP プールにある DNS 値を含める [*]
DHCP サーバデータベースに全ての DHCP オプションをインポートする [*]

VLANの設定

上記 dhcp をどのインターフェースで働かせるかを決める手順。
dhcp を使う VLAN を作り、そこに物理ポートを割り当てる。

VLANの設定
[インターフェース]の[VLAN の追加] からVLAN
VLAN ID 2
ポートの関連づけ GigaEthernet0/1-3 *0/0をWEB設定用(VLAN1)にする
IPv4 アドレス
タイプ 静的 IP アドレス
静的IPアドレス 192.168.50.1
サブネットマスク 255.255.255.0
NATの有効化 [*]
IPv6 アドレス
タイプ IP アドレスなし

VLan2から設定画面にアクセスする場合は下記のコマンドを実行してアクセス許可する

access-list 23 permit 192.168.50.0 0.0.0.255

VLan2がインターネット接続できるようにアクセス許可

object-group network local_lan_subnets ここでまず実行
192.168.50.0 255.255.255.0  

DHCP除外はターミナルで行う(100-200)

ip dhcp excluded-address 192.168.50.100 192.168.50.200

ゾーンベースのセキュリティ設定

設定は、CCPEかターミナルで行う。どちらでも良いと思う。以下のその一例、実際には必要なポサービスを開放する。

ゾーンベース
class-map type inspect match-any Others_app
match protocol pop3s
match protocol https
match protocol smtp
match protocol pop3
match protocol imap

 

固定IPの設定(PC系:client-identifier Linux系:hardware-address)

固定IPの設定は、下記のルールに従って設定する。MAcアドレスは、3つで区切ること。

AA:AA:AA:AA:AA:AA → AAAA.AAAA.AAAA

Windowsの場合、実際のMacアドレスの前に「01」を付ける。理由は分からない。

Win
ip dhcp pool 名前
host 192.168.50.*
hardware-address 01AA.AAAA.AAAA.AA
exit
Linux
ip dhcp pool 名前
host 192.168.50.*
client-identifier AAAA.AAAA.AAAA
exit

 

DHCPのバインドのクリアとIPの割り振り

clear ip dhcp binding *
show ip dhcp binding

スタートコンフィグへの登録

起動時のconfigを登録(これをしておかないと再起動時にちゃんとコンフィグがロードされない)

copy running-config startup-config

 

固定IPの登録を削除

もし、設定した固定IPのアドレスを削除したい場合は、下記のコマンドを実行する。

no ip dhcp pool 名前

 

参考サイト

  1. 武内修@筑波大 管理者/Ciscoルータ800Mの設定
  2. CISCO公式サイト
  3. Cisco 841MJ でフレッツに接続する
  4. Ciscoルーターをブロードバンドルーターとして使う  Firewall (ACL) Reflexive ACL CBACの設定